Bug: different view of the game between phone and PC

3 Replies
User
12 February, 2018, 2:12 AM UTC

I just experienced a strange and very annoying issue: at the same time, the same area of the game looked different for two players.


I am playing the browser version (plarium.com) from a PC.  A few minutes after the end of the kvk, I reconnected to the game and I sent my troops to gather resources from a tile (invader's lair).

Soon after my troops arrived, I got a message from another player who told me that his troops had been marching towards that tile for 17 minutes and he was surprised that I stole it from him.  In fact, both of us were surprised because we are at peace with each other and I would not have taken that tile if I had seen his troops coming.  The problem is that I did not see any troops going there before sending my troops, and I still did not see any troops returning after we exchanged several messages.

We even exchanged some screenshots taken around the same time: me from my PC and him from his mobile phone.  I am including two of these screenshots below.

  • The vertical image is what he saw from his mobile phone: we can see the "6" in red above the tile occupied by my troops, and the red dashed line showing that his troops were on the way but had to return.
  • The horizontal image is what I saw in my browser window: no gray lines showing his troops.
Both of these screenshots were taken around the same time (and we would have had plenty of time to do it, because his troops took 2 times 17 minutes to move) but they do not show the same thing: he sees his troops moving, but I don't.  As we are at peace and we wasted time because of that, this problem is rather frustrating for both of us.


Is this a known bug?  Has anybody seen something similar before?  What can we do to avoid having the same kind of issues in the future?


View from mobile phone


UTC +2:00
0
User
12 February, 2018, 7:47 AM UTC

Is this problem was only once? Problem could be in cache of your browser

UTC +3:00
0
User
12 February, 2018, 8:58 AM UTC

Yes this happened only once (as far as I know).

It might be a cache issue, but on the other hand I had just reloaded the game and reconnected after the end of the KvK so that should have given me a fresh map.  How likely is it that I would get stale map data from the cache after reloading the game?

I am still wondering if this is a known bug and if anybody else experienced a similar issue.

UTC +2:00
0
User
13 February, 2018, 9:51 AM UTC

I've heard about invisible marches. As far as I know, one of reason can be connected with a cache or internet connection and other technical reasons, and the second appears during events (but it just my observation) 

UTC +3:00
0
1968429 users registered; 62453 topics; 329019 posts; our newest member:anita