Security Certificate Expiration

7 Replies
rayge2005
12 March, 2017, 3:33 PM UTC
I went to purchase a pack and Firefox wasn't allowing it, says "Something went wrong with your transaction. Please try again later" It has been saying that since Saturday morning 3-11-17. Tried like a dozen times with all the results the same. Went to try and go to Community Support, and stumbled onto the problem. "Your Connection is not Secure" message. Plarium,  Firefox is telling me that you let your security certificate expire Saturday 3-11-17 at 10:00 am est. Can you please resolve this issue?
UTC +5:00
rayge2005
12 March, 2017, 4:53 PM UTC
I installed Chrome and got an "Cert_date" error also. I need help here.
UTC +5:00
primjason
12 March, 2017, 8:10 PM UTC
I am having the same issue....I bypassed the expired security certificate and sent a support ticket about this issue....One would hope they would be quick on something like this since we want to spend some money and they want our money.....
UTC +5:00
Kellrn4
12 March, 2017, 10:55 PM UTC
Same issue since early this am.  I would of thought it would be fixed by now before the packs I wanted expire.  
UTC +8:00
ymps_hound
13 March, 2017, 3:21 AM UTC
new player, wanting to purchase my first package, but can not buy, or can not submit a ticket to support, as got a bad web site, with expired certificate. 
UTC +8:00
conormaher2009
13 March, 2017, 7:06 AM UTC
me to
UTC +8:00
nikidalby_97kolm
13 March, 2017, 8:19 AM UTC
same issue went to buy POWER BEGET PACKAGE with the same results... no reply form developers as yet!!! getting frustrated 
UTC +8:00
Corgi_Viking
14 March, 2017, 8:18 AM UTC

rayge2005 said:


I installed Chrome and got an "Cert_date" error also. I need help here.

In Chrome you need to press ADVANCED and then choose "Proceed to support-portal.plarium.com (unsafe)"


Then you can write to the support team here

UTC +3:00
1661979 users registered; 33544 topics; 252651 post; our newest member:[REDRISON]