glitchy broken game

2 Replies
DevilDog
12 July, 2017, 4:21 PM UTC

Hi, ive tried to get into support but it all looks mixed up there so putting this here in hope it gets fixed. in this game people that are farming can only protect thier troops by watching the tiles they on in hopes when the enemy ports to the tile and hits they can send troops home b4 getting hit. we have the porblem where the city that ports to us is NOT SHOWING, cause there is no warning that we are being attacked we can lose all our troops without even knowing, we have to shake the screen so the city shows but thats only after being hit. u guys need to work on this and make the screen go red or some message to show and stay on screen while being attacked, something easy to see as this is stupid!!!

It is costing us gold to heal these troops, u guys should be refunding this gold due to ur glitches making our troops die!!!
UTC +7:00
Huntsman
13 July, 2017, 3:27 PM UTC
Do you have screenshots of this bugs?
UTC +7:00
ThorStone
16 July, 2017, 2:46 PM UTC

Screenshots of this bug, you are joking, rofl. screenshots of a bug from something you cant see. you take a tile, you watch the map and shake the map all few seconds, you see your troops moving home and dont know why. then you take a look at the post and there is the message you were attack at the tile. you watch the map there is no enemy. then a few seconds later again you see a castle near you tile for a second and it ports away to another place. i think it was ca 30sec later i see the enemy castle. But on the other side, if you try to attack someone at a tile, you port to the tile and this needs some seconds and then you watch the map you can see the enemy is on half way to home. dont know if this bug only happens if you use the CHROME GOOGLE APP  and play with it the game...


and you know this is a plarium game, there are NO bugs^^


many people leave this game because they go off with shield for 2 days or more and come on and having no shield, no ressource and no more troops because they was raided many times. The support only says there are no shieldbug or problems if you using shield.
UTC +1:00
1662727 users registered; 33662 topics; 253043 posts; our newest member:joeltanle04cash