Cant liberate my castle

17 Replies
dmitrij.pacaula
1 June, 2017, 10:53 AM UTC

Cant liberate my castle by my self units in catacombs and send button not working on server 1 

UTC +7:00
Alina Bright
Community Manager
1 June, 2017, 11:00 AM UTC
Hello! Do you receive an error? 
UTC +2:00
Oracle
1 June, 2017, 11:20 AM UTC

There is a bug which has been reported. When clicking on liberate, a keep menu and a recall units menu opens. The recall units menu is shielded by the keep menu. 


Calcelling the keep menu and recalling units works. But these gives the seiger a huge advantage as he can recall before you even have a time to cancell the keep menu
Just because something isn't a lie does not mean that it isn't deceptive. A liar knows that he is a liar, but one who speaks mere portions of truth in order to deceive is a craftsman of destruction.....Gedleyihlekisa: Oracle the postremogeniture
UTC +2:00
dmitrij.pacaula
1 June, 2017, 11:53 AM UTC

when i tray to liberate it saying there some issue and placing error code   error

UTC +7:00
Oracle
1 June, 2017, 12:39 PM UTC
Try clearing your cache, it should fix the issue.
Just because something isn't a lie does not mean that it isn't deceptive. A liar knows that he is a liar, but one who speaks mere portions of truth in order to deceive is a craftsman of destruction.....Gedleyihlekisa: Oracle the postremogeniture
UTC +2:00
DrFondles
2 June, 2017, 2:36 AM UTC
dmitrij.pacaula said:

when i tray to liberate it saying there some issue and placing error code   error

Have you gotten this issue fixed Lord?
Josh/Synergy S3
UTC +0:00
Alina Bright
Community Manager
2 June, 2017, 11:29 AM UTC
Thank you for your help, Lords!
UTC +2:00
alex.isakov
15 June, 2017, 6:52 PM UTC

Oracle said:


There is a bug which has been reported. When clicking on liberate, a keep menu and a recall units menu opens. The recall units menu is shielded by the keep menu. 


Calcelling the keep menu and recalling units works. But these gives the seiger a huge advantage as he can recall before you even have a time to cancell the keep menu

I got the same bug with Liberate not working at all at server 1, today just a minute ago! I recalled my units from BG - but I can't send any units to Liberate at all.

The transfer menu from Keep to Catacombes appear.

Ok, while I tried to do different things the attacker fled. What should I do?

P.S. Changing browser from Chrome to Firefox not helped at all.

UTC +4:00
brunsonthomas
15 June, 2017, 7:07 PM UTC
Have you tried the Plarium App? Many of the bugs in the Plarium browser version are not in the App.
UTC +5:00
alex.isakov
15 June, 2017, 8:15 PM UTC

brunsonthomas said:


Have you tried the Plarium App? Many of the bugs in the Plarium browser version are not in the App.

Unfortunately, it is not my way: I may not decide what to install on computer at work and partially at home as I work from home time from time.

UTC +4:00
ANBU Danzo Shimura
15 June, 2017, 8:21 PM UTC
There's two posts on this bug. On the other post i suggested you click send reinforcents instead of liberate. the other option to close the screen that pops up also could work depending on your own computer, the solution varies. Sending reinforcements to your own castle should fix the problem. i'd like to know if doesn't.
The Darkness of the Shinobi
UTC +0:00
alex.isakov
15 June, 2017, 8:40 PM UTC

ANBU Danzo Shimura said:


There's two posts on this bug. On the other post i suggested you click send reinforcents instead of liberate. the other option to close the screen that pops up also could work depending on your own computer, the solution varies. Sending reinforcements to your own castle should fix the problem. i'd like to know if doesn't.

Nope. I reload game first to see the 2 squares over keep, my one and attacker one. Then, I select Liberate in menu. Next I see window to send reinforcements, with Send and Recall buttons NOT working at all. Buttons at Catacombes worked correct, I recalled attack units to Castle from there. The attack units appeared in my castle, but nothing else happened. Send button is also working.

Going outside castle shows the siege and grayed items. I don't understand how it's possible to send reinforcements in other way to yourself.

UTC +4:00
ANBU Danzo Shimura
15 June, 2017, 11:31 PM UTC

alex.isakov said:


ANBU Danzo Shimura said:


There's two posts on this bug. On the other post i suggested you click send reinforcents instead of liberate. the other option to close the screen that pops up also could work depending on your own computer, the solution varies. Sending reinforcements to your own castle should fix the problem. i'd like to know if doesn't.

Nope. I reload game first to see the 2 squares over keep, my one and attacker one. Then, I select Liberate in menu. Next I see window to send reinforcements, with Send and Recall buttons NOT working at all. Buttons at Catacombes worked correct, I recalled attack units to Castle from there. The attack units appeared in my castle, but nothing else happened. Send button is also working.

Going outside castle shows the siege and grayed items. I don't understand how it's possible to send reinforcements in other way to yourself.

I'm going to try and run a test on my castle. Another question when you go outside your castle can you press the send reinforcements circle in the outside castle menu? If so try it that way. Another question are you willing to let someone else break the siege for you? In the mean time I can you send reinforcements in game. We might not be on the same server but i have friends on each server. I understand you might be playing at work so you can't download anything but at home you can try cc cleaner and go through the advanced options clciking delete files that are cleaned. CC cleaner can fix registry issues with your computer and browser and delete all the garbage from your computer. Watch a couple videos on how to run cc cleaner. You have to look since it's pretty technical. you can even go to setting in chrome and unclick autofill and everything that can be slowing down your browser. reset cache in the chrome settings. uninstall your browser and reinstall it. I use maxthon browser since chrome is getting more buggy on older computers. Reset cache in the chrome settings. restart computer once done. disk defragment can help also compressing all deleted files so they can be written over with new ones. so many things will take down your computer over time if you aren't running cc cleaner and disk defragment and checking for issues regularly. Check out your computers systems tools in the start menu. Visit the control pannel in start menu search also for more options to tune your computer.

The Darkness of the Shinobi
UTC +0:00
alex.isakov
16 June, 2017, 7:04 AM UTC

ANBU Danzo Shimura said:


alex.isakov said:


ANBU Danzo Shimura said:


There's two posts on this bug. On the other post i suggested you click send reinforcents instead of liberate. the other option to close the screen that pops up also could work depending on your own computer, the solution varies. Sending reinforcements to your own castle should fix the problem. i'd like to know if doesn't.

Nope. I reload game first to see the 2 squares over keep, my one and attacker one. Then, I select Liberate in menu. Next I see window to send reinforcements, with Send and Recall buttons NOT working at all. Buttons at Catacombes worked correct, I recalled attack units to Castle from there. The attack units appeared in my castle, but nothing else happened. Send button is also working.

Going outside castle shows the siege and grayed items. I don't understand how it's possible to send reinforcements in other way to yourself.

I'm going to try and run a test on my castle. Another question when you go outside your castle can you press the send reinforcements circle in the outside castle menu? If so try it that way. Another question are you willing to let someone else break the siege for you? In the mean time I can you send reinforcements in game. We might not be on the same server but i have friends on each server. I understand you might be playing at work so you can't download anything but at home you can try cc cleaner and go through the advanced options clciking delete files that are cleaned. CC cleaner can fix registry issues with your computer and browser and delete all the garbage from your computer. Watch a couple videos on how to run cc cleaner. You have to look since it's pretty technical. you can even go to setting in chrome and unclick autofill and everything that can be slowing down your browser. reset cache in the chrome settings. uninstall your browser and reinstall it. I use maxthon browser since chrome is getting more buggy on older computers. Reset cache in the chrome settings. restart computer once done. disk defragment can help also compressing all deleted files so they can be written over with new ones. so many things will take down your computer over time if you aren't running cc cleaner and disk defragment and checking for issues regularly. Check out your computers systems tools in the start menu. Visit the control pannel in start menu search also for more options to tune your computer.

If it was long-run siege, I would ask my friends or guild member, but many thanks!
It was a coiner attack, so it was 'fat' piece to hit and unfortunately I couldn't do it - the siege was removed in 1-2 minutes while I tried it.
The out-of-castle menu was inactive at all...

And about tech things, I am programmer so I understand issues good. I don't think it may have so much relation to cached data.

I consider there are some bugs in algorithms - very probably it is connected with amount of unit types which interact in last battle and with use of Legendary units so somewhere some hidden exception is thrown and not treated in right way: almost all usual and darkened types of DEF units participated from my side as well some Maranian types from attacker's side.

I have modern PC with 16Gb RAM and G4500 workhorse CPU and fast silent videocard, there are no any delay or slow draw issues and no garbage add-ons or software is installed at all. There is another bug connected with Firefox for the game, so I use Chrome (IE works good too) in the way: in Firefox you get big delays for every action.

UTC +4:00
ANBU Danzo Shimura
16 June, 2017, 9:56 AM UTC

alex.isakov said:


ANBU Danzo Shimura said:


alex.isakov said:


ANBU Danzo Shimura said:


There's two posts on this bug. On the other post i suggested you click send reinforcents instead of liberate. the other option to close the screen that pops up also could work depending on your own computer, the solution varies. Sending reinforcements to your own castle should fix the problem. i'd like to know if doesn't.

Nope. I reload game first to see the 2 squares over keep, my one and attacker one. Then, I select Liberate in menu. Next I see window to send reinforcements, with Send and Recall buttons NOT working at all. Buttons at Catacombes worked correct, I recalled attack units to Castle from there. The attack units appeared in my castle, but nothing else happened. Send button is also working.

Going outside castle shows the siege and grayed items. I don't understand how it's possible to send reinforcements in other way to yourself.

I'm going to try and run a test on my castle. Another question when you go outside your castle can you press the send reinforcements circle in the outside castle menu? If so try it that way. Another question are you willing to let someone else break the siege for you? In the mean time I can you send reinforcements in game. We might not be on the same server but i have friends on each server. I understand you might be playing at work so you can't download anything but at home you can try cc cleaner and go through the advanced options clciking delete files that are cleaned. CC cleaner can fix registry issues with your computer and browser and delete all the garbage from your computer. Watch a couple videos on how to run cc cleaner. You have to look since it's pretty technical. you can even go to setting in chrome and unclick autofill and everything that can be slowing down your browser. reset cache in the chrome settings. uninstall your browser and reinstall it. I use maxthon browser since chrome is getting more buggy on older computers. Reset cache in the chrome settings. restart computer once done. disk defragment can help also compressing all deleted files so they can be written over with new ones. so many things will take down your computer over time if you aren't running cc cleaner and disk defragment and checking for issues regularly. Check out your computers systems tools in the start menu. Visit the control pannel in start menu search also for more options to tune your computer.

If it was long-run siege, I would ask my friends or guild member, but many thanks!
It was a coiner attack, so it was 'fat' piece to hit and unfortunately I couldn't do it - the siege was removed in 1-2 minutes while I tried it.
The out-of-castle menu was inactive at all...

And about tech things, I am programmer so I understand issues good. I don't think it may have so much relation to cached data.

I consider there are some bugs in algorithms - very probably it is connected with amount of unit types which interact in last battle and with use of Legendary units so somewhere some hidden exception is thrown and not treated in right way: almost all usual and darkened types of DEF units participated from my side as well some Maranian types from attacker's side.

I have modern PC with 16Gb RAM and G4500 workhorse CPU and fast silent videocard, there are no any delay or slow draw issues and no garbage add-ons or software is installed at all. There is another bug connected with Firefox for the game, so I use Chrome (IE works good too) in the way: in Firefox you get big delays for every action.

Maxthon browser works good for me. I too had serious bug problems on my computer, a much older model. I used system recovery and wiped the hard drive to see if it will let me run this game. It did allow me to run the game for the last couple of weeks. A few problems popped up, I took a few precautions and they didn't escalate. I'm not rulling anything out yet.

I was saying on the other post it could be spaghetti coding. This meaning it's a old complicated coding that is running interference due to all the new things being added to the game effecting the old things which are complicatedly connected to the new things. From what i know it's hard to fix due to time. They can make a bunch of patched up fixes.

The real solution would be to rewrite it all more conveniently and thoughtfuly for what they're trying to do to the game so no interferances happens. I first assumed this was the problems when bg's got bugged and it was claimed they didn't touch that part of the game. i believe them and also believe it has changed due to bad coding.

I'm not a programer, I just play games on a advanced level so i need to know about bugs and fixes. it's not that serious to me since it's just a game and i play/played others.

Other players seem to be brigading all of these bugs to put pressure on plarium to fix these problems. i'm just going to sit and wait since i don't own the rights to this game or want to deal with fixing the problem.


I made these posts because it effects my players i spent hours training and my plans to improve my league. Plenty from my league have quit the game over bugs since i teach anyone and everyone who joins and talks to me. You either have to be pretty smart to get around them or have a good computer and browser relation from what I can tell so far.

The Darkness of the Shinobi
UTC +0:00
Alina Bright
Community Manager
16 June, 2017, 3:44 PM UTC
Lord, this issue will be fixed soon :) 
UTC +2:00
ANBU Danzo Shimura
16 June, 2017, 5:29 PM UTC
Eugenia Misura said:

Lord, this issue will be fixed soon :) 
Thank you.
The Darkness of the Shinobi
UTC +0:00
Alina Bright
Community Manager
19 June, 2017, 1:36 PM UTC
ANBU Danzo Shimura said:

Eugenia Misura said:

Lord, this issue will be fixed soon :) 
Thank you.
Thank you for your patience! 
UTC +2:00
1724324 users registered; 43271 topic; 271135 posts; our newest member:nurut