Attention: an issue with the latest version of the Google Chrome Flash Player

4 Replies
Basileus Leonidas
Administrator
9 July, 2015, 5:09 PM UTC

Attention, Archons!

We've faced an issue with the latest version of the Google Chrome Flash Player (Google develop and use their own Flash Player version).

In some way it incapable with the game.

In order to avoid any game crashes we suggest you to play the game using another web browser (for ex. Mozilla Firefox https://www.mozilla.org/ ) until we will fix the issue.

Thanks for your patience.

War doesn't determine who is right - only who is left.
UTC +0:00
K4ne
10 July, 2015, 8:33 PM UTC

disable flash player in chrome:plugins and enable pepper flash (integrated flash player in chrome) all will work in chrome least works for me and there was issue that game did not recognize flash player saying "u must install flash player to be able to play bla bla bla" hope it works f4 u as it worked 4 me cheers.

Its nice to be important but its more important to be nice
UTC +0:00
ThatBloke
10 July, 2015, 11:00 PM UTC

I'm still using Chromium with its dedicaded (for Chrome, I think) client. Works perfectly.

On the other hand, it's apparently imposible to update Adove Flash on Windows XP anyway, so I've actually not changed versions for this one.

I pity the fool
UTC +11:00
rbrian
14 July, 2015, 2:24 PM UTC

I am using "Firefox" and the game is now indicating that I need to load "Flash Player".  No changes were performed on the PC that I am working with.

I was able to log in initially but when I tried to refresh, the game is now failing to load altogether.

HELP PLEASE!!

UTC +0:00
Basileus Leonidas
Administrator
14 July, 2015, 4:43 PM UTC

RBRIAN, some versions of Flash were temporarily blocked in Firefox, but you can enable Flash in your browser settings.

I also suggest you to try playing the game in Chrome.

War doesn't determine who is right - only who is left.
UTC +0:00
1663322 users registered; 33851 topic; 252787 posts; our newest member:voloda.zmija