Map not panning to selected coordinates

12 Replies
Bye
28 February, 2017, 5:36 AM UTC

Summary: 

Map will not pan to a target when selecting coordinates in a form or view.

Details:

For the last few weeks, I have been experiencing a bug which is a bit difficult to pin down since it isn't readily reproducible.

When selecting coordinates, usually (but necessarily) in reports, the map view will not pan to the selected city (or capital, emporium, Persian position, pantheon), but will remain at the last map coordinates shown.  

Although this will occur ONLY when and if a position on the map has been viewed previously, it will not NECESSARILY occur every time.

An example:

  1. I click the coordinates of a player (A) in a battle report. 

  2. The app switches to map view (if not active) and pans to that position. 

  3. I select a different player (B) in a battle report. 

  4. The app switches to map view (if not active) but remains at the position of previous location (A). 

The above example will work equally no matter where one selects the coordinates; a battle report, a player from the list of coalition members, the coordinates of a Pantheon, Capital or Persian Position.

But the difficulty pinpointing this bug is that: Step 3 (see above) does not necessarily occur every time (and I have not found a common denominator). One could easily jump to 5, 10 or 15 locations on the map before encountering this bug. The only consistency is that, once this occurs, it will repeat therefore making it impossible to jump to a new map location. 

Although a refresh resolves this, that is just a stop-gap measure, after 10 or so map pans, it will pop up again.

Was wondering if anyone else is having this issue? 

Cheers

UTC +2:00
0
sarathps04
28 February, 2017, 6:00 AM UTC

Dio,

I had same issues too. But i use arrow keys instead of refreshing. If the map stuck to a position, i will use arrow keys to just move, then it will be back as usual. 

But, yes there is a problem exists in hellas.

With regards

Sarath 
UTC +5:00
2
Bye
28 February, 2017, 6:32 AM UTC

sarathps04 said:


Dio,

I had same issues too. But i use arrow keys instead of refreshing. If the map stuck to a position, i will use arrow keys to just move, then it will be back as usual. 

But, yes there is a problem exists in hellas.

With regards

Sarath 

Mornin' Sarath,

that's a good workaround since refreshes not only take a few seconds but also reset other presets, tyvm! I'll try it as soon as the issue manifests again (which should be any moment now :-), presumably it will work with my tablet's soft-keyboard as well.

Thanks & cheers
Dio

UTC +2:00
1
sarathps04
28 February, 2017, 7:01 AM UTC

Diomedes said:


sarathps04 said:


Dio,

I had same issues too. But i use arrow keys instead of refreshing. If the map stuck to a position, i will use arrow keys to just move, then it will be back as usual. 

But, yes there is a problem exists in hellas.

With regards

Sarath 

Mornin' Sarath,

that's a good workaround since refreshes not only take a few seconds but also reset other presets, tyvm! I'll try it as soon as the issue manifests again (which should be any moment now :-), presumably it will work with my tablet's soft-keyboard as well.

Thanks & cheers
Dio

Morning Dio,

Try it and let me know whether it works or not. I know, it will work, at least it works for me.

 
UTC +5:00
0
Xena
Moderator
28 February, 2017, 9:57 AM UTC
sarathps04 said:

Morning Dio,

Try it and let me know whether it works or not. I know, it will work, at least it works for me.

 
I use the arrows myself and it works perfectly fine for me too! 
Warrior Princess
UTC +2:00
1
sarathps04
28 February, 2017, 10:52 AM UTC

Xena said:


sarathps04 said:


Morning Dio,

Try it and let me know whether it works or not. I know, it will work, at least it works for me.

 
I use the arrows myself and it works perfectly fine for me too! 

Good to hear that....


UTC +5:00
0
Alyona Kolomiitseva
Community Manager
28 February, 2017, 11:13 AM UTC
Hi, Dio! Thank you for the detailed report. I could not reproduce the issue after opening 25 coords from reports, but I'll keep trying :)
Plarium Community Manager. Please note that I will be unable to respond to your private messages, review your tickets, or check your account information. All technical issues should be directed to our Support Team at plrm.me/Support_Plarium
UTC +2:00
0
Bye
28 February, 2017, 3:19 PM UTC

Alyona Kolomiitseva said:


Hi, Dio! Thank you for the detailed report. I could not reproduce the issue after opening 25 coords from reports, but I'll keep trying :)

Yes, the non-reproducible bugs are a dev's nightmare. In any case, Sarath's workaround does the job nicely (TYVM !), playing mostly on a convertible without a docked keyboard, I never thought of that.

Cheers
Dio

UTC +2:00
1
sarathps04
28 February, 2017, 3:47 PM UTC
Diomedes said:

Alyona Kolomiitseva said:


Hi, Dio! Thank you for the detailed report. I could not reproduce the issue after opening 25 coords from reports, but I'll keep trying :)

Yes, the non-reproducible bugs are a dev's nightmare. In any case, Sarath's workaround does the job nicely (TYVM !), playing mostly on a convertible without a docked keyboard, I never thought of that.

Cheers
Dio


UTC +5:00
0
Klaatu
16 March, 2017, 10:37 AM UTC

Had the same issues for month. thanks for the workaround, will give it a try!


i could reproduce the error as following:


when i do raids i have apache open office 4 started to edit an excel-sheet. if i am on the world-map and switch the tabs from open office to chrome and back then the map "freezes" as mentioned above.


maybe that helps anyone to fix this in the future.





Unser größter Ruhm ist nicht, niemals zu fallen, sondern jedes Mal wieder aufzustehen! (Nelson Mandela)
UTC -1:00
0
Alyona Kolomiitseva
Community Manager
16 March, 2017, 1:21 PM UTC
Klaatu said:

Had the same issues for month. thanks for the workaround, will give it a try!


i could reproduce the error as following:


when i do raids i have apache open office 4 started to edit an excel-sheet. if i am on the world-map and switch the tabs from open office to chrome and back then the map "freezes" as mentioned above.


maybe that helps anyone to fix this in the future.





Thanks for the way to reproduce! I'll give it a try! 
Plarium Community Manager. Please note that I will be unable to respond to your private messages, review your tickets, or check your account information. All technical issues should be directed to our Support Team at plrm.me/Support_Plarium
UTC +2:00
0
Xena
Moderator
16 March, 2017, 11:29 PM UTC

Klaatu said:


Had the same issues for month. thanks for the workaround, will give it a try!


i could reproduce the error as following:


when i do raids i have apache open office 4 started to edit an excel-sheet. if i am on the world-map and switch the tabs from open office to chrome and back then the map "freezes" as mentioned above.


maybe that helps anyone to fix this in the future.





Yes same happens to me. I have my Excel document open when I raid and when I switch tabs the map freezes.

But I use the up and down arrows to unfreeze it and everything is ok.

Doesn't happen all the times that I switch tabs but happens quite many.
Warrior Princess
UTC +2:00
0
Bye
16 March, 2017, 11:38 PM UTC

Xena said:


Klaatu said:


Had the same issues for month. thanks for the workaround, will give it a try!


i could reproduce the error as following:


when i do raids i have apache open office 4 started to edit an excel-sheet. if i am on the world-map and switch the tabs from open office to chrome and back then the map "freezes" as mentioned above.


maybe that helps anyone to fix this in the future.

Yes same happens to me. I have my Excel document open when I raid and when I switch tabs the map freezes.

But I use the up and down arrows to unfreeze it and everything is ok.

Doesn't happen all the times that I switch tabs but happens quite many.

Precisely, but this haphazard reaction makes it particularly difficult to pin down. If OOo is indeed a way to replicate this reliably, that would be a help. I had previously and tentatively ascribed this to Flash, but OOo does not use Flash in its web interface AFAIK.


UTC +2:00
0
1779773 users registered; 48311 topics; 286967 posts; our newest member:zabrodin06