All Categories

(News) Raid: Shadow Legends is now officially LIVE on PC and Mac!

(News) Raid: Shadow Legends is now officially LIVE on PC and Mac!

Search
Comments
Sep 27, 2019, 11:1809/27/19
03/16/19
274

nexxkro said:


Once I launch the raid app it just stays on the first screen but does not download the game while in raid app is there anything I can do to fix 

For anybody who get same problem likes above make sure to installed this :

- Window Xp Sp 1

- Net framework 4.8

- Visual C++ Redistributable for Visual Studio 2015. I downloaded from this link :   https://download.microsoft.com/download/9/3/F/93FCF1E7-E6A4-478B-96E7-D4B285925B00/vc_redist.x64.exe



I got same problem before. After installed all of them now the game began to downloading. But the size seems very huge. 2 hours downloading and still not finish. 

Sep 27, 2019, 22:5809/27/19
Sep 27, 2019, 23:01(edited)
11/05/15
5

I'm loving it. This is whole new experience for me. I've got emulator on old laptop but not on PC because of virtualization stuff. This is first playable big sreen and its perfect! 

It's still needs some desktop friendly features.

Like

Lock mouse scrolling on champs bars on the left in Champion house. 

Fight shortcut "T" for auto/stop fight is OK, but "I" (cap i) is not OK. When it's open for I, it needs to be closed with repeating I. 

Floating bubble on mouse hover with masteries description in Masteries tab. In whole game it will be better :-)

Bulk action for selling items, click and drag kind.. 

More Zoom out. 

----

Autoplay for free.

or/and

500 energy limit for day.

or/and

An option to lock any spells for running fight, for ex.: with clann boss.

or/and

And finally give us an option to skip whole fight.  (More time with the playing game, not only watching).

----


And then, I'll have no problem to buy some of yours clever deals. 
Cheers 


Sep 28, 2019, 06:4609/28/19
08/28/19
4

Valcha said:


Very high cpu usage, over 90-100%, GPU - 25/30% is it normal?

Changed settings from Low to Ultra and back Low, game runs fine, no stutters.

My PC for reference.

CPU - Intel Core i5/4690k

GPU - Nvidia GeForce GTX 980 Ti 6 gb

MOBO - Asus Z97 Pro Gamer

RAM - Kingston 16GB PC14900 DDR3 CL9 HyperX Savage

PSU - Corsair RMx Series 750W

I did some quick & nasty testing changing the graphic quality settings (low, med, high & ultra) and the frame rate settings (30, 60 & unlimited FPS). I tried every combination of the choices available and the results for my PC ranged from 10-15% GPU usage & 7-9% CPU usage for LOW/30FPS upto 86-99% GPU usage & 27-33% CPU usage for ULTRA/UNLIMITED. I'll be using HIGH/60FPS (44-48% GPU & 9-14% CPU) for now.

The relevant specs for my PC are Intel Core i7-7700 CPU, 16Gb DDR3 RAM & NVIDIA GeForce GTX 1060 6Gb video card.

Oh, and the PC client absolutely rocks as everyone else has already said. Thanks Plarium.
Sep 28, 2019, 09:0109/28/19
11/20/15
1
wow! great work Plarium ! the focus blur and sharpness in the PC game is amazing! 
Sep 28, 2019, 14:3309/28/19
Sep 29, 2019, 09:22(edited)
04/26/19
11

It runs way better than using BlueStacks on MacOS Catalina so far. 


That said, the PlariumPlay platform does use up alot of CPU power (see image).


The platform asks for permission to keystrokes and inputs from all applications, why? And why do you need access to all files in my documents folder?


Sep 28, 2019, 20:2509/28/19
08/08/19
2

The game is working on my laptop just fine!

And it looks good! Thank you! I prefer playing on my laptop :) 
Sep 29, 2019, 02:2209/29/19
Sep 29, 2019, 02:23(edited)
06/14/19
2

My plarium account was connected to my facebook acount on mobile, so when I login on mobile i click 'login using facebook'.

However when I installed PC client and logged in using facebook on the PC client (same facebook account), it has created a new raid profile and my mobile account is not on PC version.


What did I do wrong? Is there any way to fix this?

Dec 10, 2019, 19:2512/10/19
Dec 10, 2019, 19:25(edited)
05/13/19
1

Hi.


Playing Raid-Shadow Legends via PlariumPlay. Having issues with harddisk getting filled with .. stuff. PlariumPlay.exe writing on harddisk nonstop until end of disk is reached after 75GB. See screenshot for high amount of written data.


PlariumPlay installed on a user account, but only appears on Admin desktop. Create shortcut also only works for Admin account, although task is given from user account. Running on Admin account seems to run without issue. But that is not what an admin account is for, right?

System: Win 7 Home Premium, SP1

Plarium Version: v5.00 (4.1.1.-1950)





Update 10. Dec


Even on admin account the harddisk is loaded all the time. What`s even worse the diskspace is not freed again after closing down, shut-down and restart or by dos clean-up and repair tool... diskspace loss of 20 GB until I stopped the game and closed PlariumPlay.

Sad thing, game was running well, no disruptions and faster than on mobile device. But I can not use the desktop app as it is. Hope you can fix this.


The topic is locked. You cannot post comments.