90 Login reward not recieved

4 Replies
jujubee12
1 January, 2017, 6:12 AM UTC
Logged in for 90 days straight and was shown the 90 day reward number as well as the reward in the opening window. But, when i went to check for the reward, specifically the Agemas since that is what i saw first and remembered form the reward box. There were no Agemas in the city or Acropolis. Since my own Agemas were out on a raid there was 'zero' in the city after the login and reward screen. Please fix and reimburse for the lost 90th day login reward. thanks.
UTC +4:00
Drag-Theseus
Moderator
2 January, 2017, 10:23 PM UTC

You need to wait until time is up(runs out) Archon.

This was probably your problem.. 


Did you recieve your reward?
I'm just Time Lord....
UTC +7:00
Prometheus
4 January, 2017, 8:43 AM UTC

Hello Archon and Happy new Years to you and to your family!

Unfortunately we cannot help you on the forums on this kind of issue. Please contact our support team.

UTC +4:00
jujubee12
5 January, 2017, 10:25 PM UTC
No I did not get my reward for 90 days straight login. And yes I logged in and was shown the 90th day flag up top to click to get to the rewards screen.
UTC +4:00
Alyona Kolomiitseva
Community Manager
6 January, 2017, 11:35 AM UTC
jujubee12 said:

No I did not get my reward for 90 days straight login. And yes I logged in and was shown the 90th day flag up top to click to get to the rewards screen.
Have you contacted Support as it was suggested above?
Plarium Community Manager. Please note that I will be unable to respond to your private messages, review your tickets, or check your account information. All technical issues should be directed to our Support Team at plrm.me/Support_Plarium
UTC +2:00
1723885 users registered; 43102 topics; 270914 posts; our newest member:Castle №1254053